A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 372473 Accepted Submission(s): 72570
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
Author
Ignatius.L
Recommend
We have carefully selected several similar problems for you: 1008 1005 1093 1092 1009
代码实现:
import java.math.BigInteger;
import java.util.Scanner;
public class Main { // 注意提交的时候要 改为Main
public static void main(String args[]){
Scanner s=new Scanner(System.in);
int n=s.nextInt();
for(int i=1;i<=n;i++){
BigInteger a=s.nextBigInteger();
BigInteger b=s.nextBigInteger();
BigInteger c=a.add(b);
if(i>1) System.out.println();
System.out.println("Case "+(i)+":");
System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
}
}
}
// 建议 用java做 因为 BigInteger 理论上可以表示无限大的数只要内存够
// 如果用C的话 就要考虑 用字符串的相加来做。
提交代码