HDU OJ 1002 A + B Problem II

本文介绍了一个名为“A+B Problem II”的编程题目,该题目要求计算两个大整数的和,并提供了一个使用Java语言的示例代码,利用BigInteger类来处理大整数运算。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 372473    Accepted Submission(s): 72570


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1008 1005 1093 1092 1009 



代码实现:


import java.math.BigInteger;

import java.util.Scanner;

public class Main {    //  注意提交的时候要 改为Main

    public static void main(String args[]){
        Scanner s=new Scanner(System.in);
        int n=s.nextInt();
        for(int i=1;i<=n;i++){
            BigInteger a=s.nextBigInteger();
            BigInteger b=s.nextBigInteger();
            BigInteger c=a.add(b);
             if(i>1) System.out.println();
            System.out.println("Case "+(i)+":");
            System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
        }
    }
}

// 建议 用java做 因为 BigInteger 理论上可以表示无限大的数只要内存够 
// 如果用C的话 就要考虑 用字符串的相加来做。
提交代码


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值