kuangbin KMP H题

本文介绍了一种用于寻找字符串中前后缀匹配部分的高效算法。通过使用next数组来优化搜索过程,该算法能快速找到所有可能的前后缀匹配,并输出它们的长度。适用于处理大量字符串数据的应用场景。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

H - Seek the Name, Seek the Fame

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

题解:

next数组的妙用。
仔细观察。
最小的前后缀一定在比他长的前后缀中出现过。
我们可以利用这一性质,[0,next[i]]出现过一定在[0,i]出现过。
141ms

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

const int MAXN = 400000 + 10;

char str[MAXN];
int len;
int nt[MAXN];

void getNext()
{
    nt[0] = -1;
    int i = 0, j = -1;
    while (i <= len)
    {
        if (j == -1 || str[i] == str[j])
        {
            nt[++i] = ++j;
        }
        else
        {
            j = nt[j];
        }
    }
}
vector<int> ans;
int main()
{
    while(scanf("%s",str)!=EOF)
    {
        len = strlen(str);
        getNext();

        while(len>0)
        {
            ans.push_back(len);
            len=nt[len];
        }
        int siz = ans.size();

        for(int i=siz-1;i>=1;i--)
        {
            printf("%d ",ans[i]);
        }
        printf("%d\n",ans[0]);
        ans.clear();

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值