浙江大学PAT_甲级_1047. Student List for Course (25)

本文介绍了一个简单的课程注册统计系统的设计与实现。系统接收输入文件,包含学生名单、选课数量及课程编号,输出每门课程的注册学生名单,并按字母顺序排列。采用C++编程语言实现,利用二维动态数组存储课程信息。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:点击打开链接

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
我的C++代码:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	vector< vector<string>> CourseInfomation;
	//二维动态数组存储课程信息,CourseInfomation[i]数组记录选择i号课程的学生名字
	CourseInfomation.resize(2501);//设置大小为2501
	int n, k;//n学生人数,k课程数量
	int i = 0, j = 0, CourseSum, CourseID;//CourseSum一位学生选择的课程总数,CourseID选择的课程编号
	string name;//学生名字
	scanf("%d %d", &n, &k);
	for (i = 0; i < n; i++)
	{
		cin >> name;
		scanf("%d", &CourseSum);
		for (j = 0; j < CourseSum; j++)
		{
			scanf("%d", &CourseID);
			CourseInfomation[CourseID].push_back(name);//记录学生名字,放进数组CourseInfomation[CourseID]
		}
	}
	for (i = 1; i <= k; i++)
	{
		printf("%d %d\n", i, CourseInfomation[i].size());//输出选择该课程的人数
		sort(CourseInfomation[i].begin(), CourseInfomation[i].end());//对学生的姓名进行排序
		for (auto j : CourseInfomation[i])
		{
			cout << j;//输出学生姓名
			printf("\n");//这里用printf,不然运行超时
		}
	}
	//system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值