POJ3094-Quicksum解题报告

本文深入探讨了Quicksum算法的原理与应用,通过实例展示了如何计算Quicksum值,并提供了完整的代码实现。Quicksum是一种用于数据校验的算法,特别适用于检测数据传输错误或验证文档内容的一致性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Quicksum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10876 Accepted: 7489

Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

        ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

Sample Output

46
650
4690
49
75
14
15
 
#include<iostream>
using namespace std;

int value[100];

void setvalue(){
	int i = 1, num;
	value[' '] = 0;
	for(num = 'A'; num <= 'Z'; num ++){
		value[num] = i;
		i++; 
		}
	}

int main(){
	setvalue();
	char characters[10000];
	int i,j,sum = 0,length;
	while(1){
		gets(characters);
		if(!strcmp(characters,"#")){
			return 0;
			}
			length = strlen(characters);
			
			for(i = 0;i <= length; i++){
				sum += value[characters[i]]*(i+1);
				}
				cout << sum <<endl;
				sum = 0;
		}
	
	system("pause");
	return 0;
	}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值