A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 103847    Accepted Submission(s): 19694


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 
#include<iostream>
using namespace std;
int main()
{
	char zifu[1001],zifu1[1001];
	int shuzi[1001],shuzi1[1001],he[1001],s1,s2,s,sum,t=1,i,j,n;
	cin>>n;
	while(n--)
	{
	cin>>zifu>>zifu1;
	s1=strlen(zifu);
	s2=strlen(zifu1);
	memset(shuzi,0,sizeof(shuzi));
	memset(shuzi1,0,sizeof(shuzi1));
	memset(he,0,sizeof(he));
	cout<<"Case "<<t<<':'<<endl;
	cout<<zifu<<' '<<'+'<<' '<<zifu1<<' '<<'='<<' ';
	for(i=s1-1,j=0;i>=0;i--,j++)
		shuzi[j]=zifu[i]-'0';
	for(i=s2-1,j=0;i>=0;i--,j++)
		shuzi1[j]=zifu1[i]-'0';
	if(s1>s2)
		s=s1;
	else
		s=s2;
	for(i=0;i<=s;i++)
	{
		sum=shuzi[i]+shuzi1[i];
		if(sum>=10)
		{
			shuzi[i+1]++;
			he[i]=sum%10;
		}
		else
			he[i]=sum;
	}
	if(he[s]==1)
		cout<<he[s];
	for(i=s-1;i>=0;i--)
		cout<<he[i];
	cout<<endl;
	if((n-1)>=0)
		cout<<endl;
	t++;
	}
	return 0;
}
欢迎交流:QQ 594954848
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值