题目来源:中国大学MOOC-陈越、何钦铭-数据结构-2018春
作者: 陈越
单位: 浙江大学
问题描述:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
解答:模拟栈的运行,把1-N依次放入栈中,模拟,看能不能顺利全部弹出栈。
#include <iostream>
#include <stack>
using namespace std;
stack<int> moni;
int main()
{
int MaxSize,N,testN;
cin>>MaxSize>>N>>testN;
int test[1001];
for(int j=1; j<=testN; j++)
{
while(!moni.empty())
{
moni.pop();
}
for(int i=1; i<=N; i++)
cin>>test[i];
int i=1,temp=1;
bool flag=true;
while(i<=N)
{
moni.push(i);
if(moni.size()>MaxSize)
{
flag=false;
break;
}
while(!moni.empty()&&test[temp]==moni.top())
{
moni.pop();
temp++;
}
i++;
}
if(!moni.empty())
flag=false;
if(flag)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
return 0;
}