UVA 11609 Teams

Question:
In a galaxy far far away there is an ancient game played among the planets. The specialty of the game
is that there is no limitation on the number of players in each team, as long as there is a captain in
the team. (The game is totally strategic, so sometimes less player increases the chance to win). So the
coaches who have a total of N players to play, selects K (1 ≤ K ≤ N) players and make one of them
as the captain for each phase of the game. Your task is simple, just find in how many ways a coach
can select a team from his N players. Remember that, teams with same players but having different
captain are considered as different team.
Input
The first line of input contains the number of test cases T ≤ 500. Then each of the next T lines contains
the value of N (1 ≤ N ≤ 109
), the number of players the coach has.
Output
For each line of input output the case number, then the number of ways teams can be selected. You
should output the result modulo 1000000007.
For exact formatting, see the sample input and output.
Sample Input
3
1
2
3
Sample Output
Case #1: 1
Case #2: 4
Case #3: 12
题意大意:有n个人,教你选出其中一人或多人去参加比赛,并选出一名队长,让你计算有多少种方案(如果人一样,但队长不同为一种新的方案)
思路:如果仔细去思考不难发现其和为sum=i*C(i(上标),n(下标))(1<=i<=n)求和。然后i*C(i,n)=i*n!/(i!(n-i)!)=n((n-1)!/((i-1)!*(n-i)!)=n*c(i-1,n-1)然后再求和等于sum=n*2^(n-1),这样就将问题转化为了一个简单的数学问题。是不是很巧妙。
(http://acm.hust.edu.cn/vjudge/contest/121559#problem/G)

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const LL MOD=1e9+7;
LL quick_mod(LL a,LL b)
{
    LL res=1;
    while (b)
    {
        if(b&1)
            res=(res*a)%MOD;
        b>>=1;
        a=a*a%MOD;
    }
    return res;
}
int main()
{
    int n,t;
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        cin>>n;
        cout<<"Case #"<<i<<": "<<quick_mod(2,n-1)*n%MOD<<endl;
    }
}

体会:做题时要仔细观察,并将这种组合求和转化为简单的数学问题。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值