Hidden String
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1688 Accepted Submission(s): 595
Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string
s
of length
n
. He wants to find three nonoverlapping substrings
s[l
1
..r
1
]
,
s[l
2
..r
2
]
,
s[l
3
..r
3
]
that:
1. 1≤l
1
≤r
1
<l
2
≤r
2
<l
3
≤r
3
≤n
2. The concatenation of s[l
1
..r
1
]
,
s[l
2
..r
2
]
,
s[l
3
..r
3
]
is "anniversary".
1. 1≤l
2. The concatenation of s[l
Input
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤100)
, indicating the number of test cases. For each test case:
There's a line containing a string s
(1≤|s|≤100)
consisting of lowercase English letters.
There's a line containing a string s
Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
Sample Input
2 annivddfdersewwefary nniversarya
Sample Output
YES NO
暴力列举每一段的长度,把目标字符串分为三段。用strstr函数找到第一次出现字符串的地址
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char aim[]="anniversary",s[110],s1[110];
int main()
{
int i,j,k,m,flag,n,len,l,loca;
len=strlen(aim);
scanf("%d",&m);
while(m--)
{
scanf("%s",s);
flag=0;
for(i=0;i<=8;i++)
{
for(j=i+1;j<=9;j++)
{
strcpy(s1,aim);
s1[i+1]='\0';
l=strstr(s,s1)-s;
if(l<0)
continue;
l+=i+1;
strcpy(s1,aim+i+1);
s1[j-i]='\0';
l=strstr(s+l,s1)-s;
if(l<0)
continue;
l+=j-i;
strcpy(s1,aim+j+1);
l=strstr(s+l,s1)-s;
if(l<0)
continue;
flag=1;
break;
}
if(flag)
break;
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}