Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
100
).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
#include<iostream>
using namespace std;
int main(){
string s;
cin>>s;
int sum=0;
for(int i=0;i<s.length();i++)
sum+=(s[i]-'0');
string array=to_string(sum);
string num[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
//不要用string[10][n],n多大都不行,会输出16进制,应该是地址,原理暂不清楚
cout<<num[array[0]-'0'];
for(int i=1;i<array.length();i++)
cout<<" "<<num[array[i]-'0'];
return 0;
}