5311 Exponentiation

Problem D: Exponentiation

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 5   Solved: 4
[ Submit][ Status][ Web Board]

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of R N where R is a real number ( 0.0 < R < 99.999) and n is an integer such that  (0 < n < 26).

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

HINT

解题思路:

    1、大数的n次方。

    2、利用大数的乘法。

    3、处理大数字符串,去小数点并记录它的位置。

    4、得到的值如果位数比小数点的位数要低,则先打'.'然后补0


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define Max 550

int cake[Max];
char c_a[Max],c_b[Max];
char result[Max],change[Max];

void Mul(char c_a[], char c_b[]) {
	int count=0,i,j;
	memset(cake,0,sizeof(cake));
	memset(result,'\0',sizeof(result));
	int na = strlen(c_a);
	int nb = strlen(c_b);
	for (i=na-1; i>=0; i--) {
		for (j=nb-1; j>=0; j--) {
			cake[i+j+1] = cake[i+j+1] + (c_a[i]-'0') * (c_b[j]-'0');
		}
	}
	for (i=na+nb-1; i>=0; i--) {
		cake[i] = cake[i] + count;
		count = cake[i] / 10;
		cake[i] = cake[i] % 10;
	}
	for (i=0; !cake[i] && i<na+nb-1; i++) {
		
		
	}
	j=0;
	for ( ; i<na+nb; i++) {
		result[j++] = cake[i] + '0';
	}
}

int main() {
    int b,key;
	while (~scanf("%s %d",c_a,&b)) {
		int i, j;
		key = 0;
		bool flag = false;
		for (i=strlen(c_a)-1,j=0;i>=0;i--) {
			
			if (c_a[i] == '.') {
				key = j;
				continue;
			}
			if (c_a[i] != '0')
				flag = true;
			if (flag) {
				change[j] = c_a[i];
				c_b[j++] = c_a[i];
			}
		}
		change[j] = '\0';
		c_b[j] = '\0';
		//printf("%s %s\n",change,c_b);
		for (i=0;i<j/2;i++) {
			char p = change[i];
			change[i] = change[j-i-1];
			change[j-i-1] = p;
			p = c_b[i];
			c_b[i] = c_b[j-i-1];
			c_b[j-i-1] = p;
		}
		//printf("%s %s key=%d\n",change,c_b,key);
		for (j=1;j<b;j++) {
			Mul(change,c_b);
			for (i=0; result[i]!='\0'; i++) {
				change[i]=result[i];
			}
			change[i] = '\0';
		}
		//printf("%d\n",b);
		if (key*b-1 > strlen(change)) {
			printf(".");
			for (i=0; i<=key*b-1-strlen(change); i++) {
				printf("0");
			}
		}
		for (i=0; change[i]!='\0'; i++) {
			if (i == strlen(change)-key*b) {
				printf(".");
			}
			printf("%c",change[i]);
		}
		
		printf("\n");
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值