Problem A: Integer Inquiry
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 37 Solved: 16
[ Submit][ Status][ Web Board]
Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input
The input will consist of at most 1000 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 1000 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
HINT
解题思路:
1、大整数求和,直接用字符串就能解决
2、没有小数点,很简单
3、不知道为什么,用char字符串时间超限,用string才AC 。所以代码有点乱
#include <stdio.h>
#include <iostream>
#include <string>
using namespace std;
string add_bigNumber(string newstr, string results)
{
char transfers[2000];
int len_n = newstr.length();
int len_r = results.length();
int t=0; //叠加器
int sum,i,j,k;
for (i=len_n-1,j=len_r-1,k=0; i>=0&&j>=0; i--,j--)
{
sum = (newstr[i]-'0') + (results[j]-'0') + t;
transfers[k++] = (sum % 10) + '0';
t = sum / 10;
}
if (i >= 0)
{
while (i >= 0)
{
sum = (newstr[i] - '0') + t;
transfers[k++] = (sum % 10) + '0';
t = sum / 10;
i--;
}
}
else if (j >= 0)
{
while (j >= 0)
{
sum = (results[j] - '0') + t;
transfers[k++] = (sum % 10) + '0';
t = sum / 10;
j--;
}
}
if (t>0)
transfers[k++] = t + '0';
transfers[k] = '\0';
char tran[2000];
j = 0;
for (i=k-1; i>=0; i--)
{
tran[j++] = transfers[i];
}
tran[j] = '\0';
string s(tran);
//cout << s << endl;
return s;
}
int main()
{
string newstr;
string results;
cin>>newstr;
results = newstr;
while(cin>>newstr)
{
if (newstr[0]=='0')
break;
results = add_bigNumber(newstr,results);
//cout << results << endl;
}
cout<<results<<endl;
return 0;
}