Problem C: Immediate Decodability
Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
The Sample Input describes the examples above.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
解题思路:
找有没有前缀,还行
1、暴力,两重for循环,将每两个字符串相互比较一下
2、在循环里进行比较,注意循环结束条件
3、计数,针对输出不同答案
找有没有前缀,还行
1、暴力,两重for循环,将每两个字符串相互比较一下
2、在循环里进行比较,注意循环结束条件
3、计数,针对输出不同答案
#include <stdio.h>
#include <string.h>
int main ()
{
char c[20][20];
int i=0,count=1;
while (scanf("%s",c[i++])!=EOF)
{
if (c[i-1][0]=='9')
{
int flag = 0,team=0;
for (int j=0;j<i;j++)
{
for (int k=j+1;k<i;k++)
{
team = 0;
for (int t=0;t<strlen(c[j])&&t<strlen(c[k]);t++)
{
if (c[j][t]!=c[k][t])
{
team = 1;
break;
}
}
if (team==0)
{
flag = 1;
break;
}
}
if (flag==1)
{
printf("Set %d is not immediately decodablen",count++);
break;
}
}
if (flag == 0)
printf("Set %d is immediately decodablen",count++);
i=0;
}
}
return 0;
}