/*
* =====================================================================================
*
* Filename: hdu2052.c
*
* Description:
*
* Version: 1.0
* Created: 2013年11月17日 21时44分18秒
* Revision: none
* Compiler: gcc
*
* Author: Wenxian Ni (Hello World~), niwenxianq@qq.com
* Organization: AMS/ICT
*
* =====================================================================================
*/
/*
Picture
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13772 Accepted Submission(s): 7113
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
| |
| |
+---+
*/
#include <stdio.h>
int main()
{
int m,n;
int i,j;
while(~scanf("%d %d",&m,&n))
{
printf("+");
for(i=0;i<m;i++)
{
printf("-");
}
printf("+\n");
for(i=0;i<n;i++)
{
printf("|");
for(j=0;j<m;j++)
printf(" ");
printf("|\n");
}
printf("+");
for(i=0;i<m;i++)
{
printf("-");
}
printf("+\n\n");
}
return 0;
}
说明:
1. 每个case之后还要有一行