HDU-1260
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am
**每一个人可以自己买,也可以和前面的或后面的人一起买,也就相当于,对这个人来说有两种选择,自己买,或者和前面的人一起买。
即:dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]),dp[i]代表i个人花费的最短时间,a[i]表示第i个人花费的时间,b[i]表示第i个人和前一个人一共花费的时间,就最小值就行。
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[2010],b[2010],dp[2010];
int main()
{
int t,n,i;
scanf("%d",&t);
while(t--)
{
int sum=0,h,m,s;
scanf("%d",&n);
for(i = 1;i <= n; i++)
scanf("%d",&a[i]);
for(i = 2;i <= n; i++)
scanf("%d",&b[i]);
dp[0]=0,dp[1]=a[1];
for(i = 2;i <= n; i++)
dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
s=dp[n]%60,m=(dp[n]/60)%60;
h=8+(dp[n]/60/60);
if(h <= 12)
printf("%02d:%02d:%02d am\n",h,m,s);
else printf("%02d:%02d:%02d bm\n",h-12,m,s);
}
}