Cinema in Akiba(线段树求解位置)

题目链接:Cinema in Akiba

Cinema in Akiba
Time Limit: 3 Seconds Memory Limit: 65536 KB
Cinema in Akiba (CIA) is a small but very popular cinema in Akihabara. Every night the cinema is full of people. The layout of CIA is very interesting, as there is only one row so that every audience can enjoy the wonderful movies without any annoyance by other audiences sitting in front of him/her.

The ticket for CIA is strange, too. There are n seats in CIA and they are numbered from 1 to n in order. Apparently, n tickets will be sold everyday. When buying a ticket, if there are k tickets left, your ticket number will be an integer i (1 ≤ i ≤ k), and you should choose the ith empty seat (not occupied by others) and sit down for the film.

On November, 11th, n geeks go to CIA to celebrate their anual festival. The ticket number of the ith geek is ai. Can you help them find out their seat numbers?

Input
The input contains multiple test cases. Process to end of file.
The first line of each case is an integer n (1 ≤ n ≤ 50000), the number of geeks as well as the number of seats in CIA. Then follows a line containing n integers a1, a2, …, an (1 ≤ ai ≤ n - i + 1), as described above. The third line is an integer m (1 ≤ m ≤ 3000), the number of queries, and the next line is m integers, q1, q2, …, qm (1 ≤ qi ≤ n), each represents the geek’s number and you should help him find his seat.

Output
For each test case, print m integers in a line, seperated by one space. The ith integer is the seat number of the qith geek.

Sample Input
3
1 1 1
3
1 2 3
5
2 3 3 2 1
5
2 3 4 5 1
Sample Output
1 2 3
4 5 3 1 2

题意:给你n个人的票a[i],代表这个人要坐第几个空位置(是空位置),有m个询问q[i],问你q[i]坐在了几号位置上。

思路:线段树,求解第i个空位置在哪里。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include<string.h>
#include <map>
#include<stack>
#include<queue>
#include <vector>
#include <set>
#include <math.h>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int maxn=5e4+9;

struct node
{
    int l,r;
    int sum;
} edge[maxn*4];
int a[maxn];

void build(int num,int l,int r)//建树
{
    int mid=(l+r)/2;
    edge[num].l=l;
    edge[num].r=r;
    edge[num].sum=1;
    if(l==r)
        return ;
    build(num<<1,l,mid);
    build(num<<1|1,mid+1,r);
    edge[num].sum=edge[num<<1].sum+edge[num<<1|1].sum;
}
void update(int num,int x,int i)//查找第x个空位在哪
{
    int l=edge[num].l,r=edge[num].r,mid=(l+r)/2;
    if(l==r)
    {
        edge[num].sum--;
        a[i]=l;
        return ;
    }
    if(edge[num<<1].sum>=x)
        update(num<<1,x,i);
    else update(num<<1|1,x-edge[num<<1].sum,i);
    edge[num].sum=edge[num<<1].sum+edge[num<<1|1].sum;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        build(1,1,n);
        for(int i=0; i<n; i++)
        {
            int x;
            scanf("%d",&x);
            update(1,x,i+1);
        }
        int m;
        int x;
        scanf("%d",&m);
        for(int i=0; i<m-1; i++)
        {
            scanf("%d",&x);
            printf("%d ",a[x]);
        }
        scanf("%d",&x);
        printf("%d\n",a[x]);
    }

    return 0;
}
期末大作业基于python的足球运动员数据分析源码+数据集(高分项目),个人经导师指导并认可通过的高分设计项目,评审分98分,项目中的源码都是经过本地编译过可运行的,都经过严格调试,确保可以运行!主要针对计算机相关专业的正在做大作业、毕业设计的学生和需要项目实战练习的学习者,资源项目的难度比较适中,内容都是经过助教老师审定过的能够满足学习、使用需求,如果有需要的话可以放心下载使用。 期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于python的足球运动员数据分析源码+数据集(高分项目)期末大作业基于pyth
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值