HDU 2899 Strange fuction 三分

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534


题目的意思就是给你1个 y(0 < Y <1e10)  求F(x)的的最小值在区间[0,100]

首先观察这个式子 显然是先减后增的 那么两种方法 一种是手动求个导 算x=0 用二分

我用的是三分求极值其实差不多太多,还是比较容易的。

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
long long  y;
const double eps= 1e-6;
double calc(double x)
{
    return (6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x);
}
double three(double l,double r)
{
    double mid,midmid;
    while(l+eps<r)
    {
        mid=(l+r)/2;
        midmid=(mid+r)/2;
        if(calc(mid)<calc(midmid)) r=midmid;
        else l=mid;
    }
    return mid;
}


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&y);
        double x = three(0.0,100.0);
        printf("%.4lf\n",calc(x));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值