When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] ... hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<cstring>
#include<stack>
using namespace std;
const int maxn = 1010;
int n,num=0,father[maxn], work[maxn], hashtable[maxn] = { 0 };
int findf(int x) {
int a = x;
while (x != father[x])
x = father[x];
while (a != father[a]) {
int z = a;
a = father[a];
father[z] = x;
}
return x;
}
void un(int a, int b) {
int fa = findf(a);
int fb = findf(b);
if (fa != fb) father[fa] = fb;
}
void ini() {
for (int i = 1; i <= n; i++) {
father[i]=i;
}
}
bool cmp(int a, int b) {
return a > b;
}
int main() {
scanf("%d", &n);
ini();
int k,tmp;
memset(work,0,sizeof(work));
for (int i = 1; i <= n; i++) {
scanf("%d:", &k);
for (int j = 0; j < k; j++) {
scanf("%d", &tmp);
if (work[tmp] == 0) {
work[tmp] = i;
}
else {
un(work[tmp], i);
}
}
}
for (int i = 1; i <= n; i++) {
hashtable[findf(i)]++;
if (hashtable[findf(i)] == 1) num++;
}
printf("%d\n", num);
sort(hashtable+1, hashtable + n+1,cmp);
for (int i = 1; i <= num; i++) {
printf("%d", hashtable[i]);
if (i < num) printf(" ");
}
return 0;
}