杭电oj--Constructing1025(dp+二分)

文章描述了一个关于在一个资源分布不均的王国中,如何在满足特定条件(不能建交叉路)下最大化连接贫瘠城市与富裕城市的道路数量的问题,通过二分搜索和动态规划算法求解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
 
 
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
 
 
Case 1: My king, at most 1 road can be built.
Case 2: My king, at most 2 roads can be built.
二分
import java.util.*;

public class Main {
    static int max, n;
    static int[] arr, b;

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int x = 0;
        while (sc.hasNext()) {
            x++;
            n = sc.nextInt();
            arr = new int[n + 1];
            for (int i = 1; i <= n; i++) {
                sc.nextInt();//贫瘠城市
                arr[i] = sc.nextInt();//富裕城市
            }
            max = 1;
            b = new int[n + 1];
            b[1] = arr[1];
            for (int i = 2; i <= n; i++) {
                if (arr[i] > b[max]) {
                    b[++max] = arr[i];
                } else {
                    int len = find(arr[i]);
                    b[len] = arr[i];
                }
            }
            System.out.println("Case " + x + ":");
            System.out.println("My king, at most " + max + " road can be built.");
            System.out.println();
        }
    }

    private static int find(int i) {
        int l = 1, r = max;
        while (l <= r) {
            int mid = l + (r - l) / 2;
            if (i > b[mid]) {
                l = mid + 1;
            } else r = mid - 1;
        }
        return l;
    }
}

dp

import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int x = 0;
        while (sc.hasNext()) {
            x++;
            int n = sc.nextInt();
            int[] arr = new int[n + 1];
            for (int i = 1; i <= n; i++) {
                sc.nextInt();//贫瘠城市
                arr[i] = sc.nextInt();//富裕城市
            }
            int[] dp = new int[n + 1];
            int max = 1;
            for (int i = 1; i <= n; i++) {
                dp[i] = 1;
                for (int j = 1; j < i; j++) {
                    if (arr[i] > arr[j]) {
                        dp[i] = Math.max(dp[i], dp[j] + 1);
                        max = Math.max(max, dp[i]);
                    }

                }
            }
            System.out.println("Case " + x + ":");
            System.out.println("My king, at most " + max + " road can be built.");
            System.out.println();
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

.无聊人.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值