A1086 Tree Traversals Again已知先序和中序求后序

1086 Tree Traversals Again分数 25

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

有序的二进制树遍历可以用堆栈以非递归的方式实现。例如,假设遍历一个6节点的二叉树(密钥从1到6)时,堆栈操作为:push(1);push(2);push(3);pop();pop();push(4);pop();pop();push(5);push(6);pop();pop()。然后,可以从这个操作序列中生成一个唯一的二叉树(如图1所示)。您的任务是给出这棵树的后序遍历序列。

Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1
#include<iostream>
#include<stack>
#include<cstring>
#include<cstdio>
using namespace std;

struct node{
    int data;
    node* lchild;
    node* rchild;
    
};
//push前序序列,pop中序序列
int pre[61],in[61],post[61];
int n;

//先建树
//前 根左右,中左根右
node* create(int prel,int prer,int inl,int inr){
    if(prel>prer)return NULL;
    node* root=new node;
    root->data=pre[prel];
    int i;
    for(i=inl;i<=inr;i++){
        if(in[i]==pre[prel])break;//找到根后,根为i
    }
    int numleft=i-inl;//左子树大小
    root->lchild=create(prel+1,numleft+prel,inl,i-1);
    root->rchild=create(numleft+prel+1,prer,i+1,inr);
    return root;
}

//后序遍历
int sum=0;//已输出的节点个数
void postorder(node* root){
    if(root==NULL)return;
    postorder(root->lchild);
    postorder(root->rchild);
    printf("%d",root->data);
    sum++;
    if(sum<n)cout<<" ";
}

int main(){
    cin>>n;
    char str[5];
    stack<int> st;//栈
    int x,preindex=0,inindex=0;//入栈元素x,序列下标
    for(int i=0;i<2*n;i++){//出栈入栈共2n次
        //scanf("%s",str);
        cin>>str;//两种表示方法
        if(strcmp(str,"Push")==0){//两字符串相同strcmp返回0    
            //strcmp只能用在char,不能用string
            //入栈
            scanf("%d",&x);
            pre[preindex++]=x;
            st.push(x);
        }
        else{//否则出栈
            in[inindex++]=st.top();
            st.pop();
        }
    }
    
    node* root=create(0,n-1,0,n-1);//建树
    postorder(root);
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值