(Java)PAT (Basic Level) 1081 检查密码 (15 分)

问题描述:

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

代码:

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String sn = sc.nextLine();
		int n = Integer.parseInt(sn);
		int cntn = 0, cntw = 0;
		OUT:
		for(int i=0;i<n;i++) {
			String s = sc.nextLine().toLowerCase();
			if(s.length()<6) {
				System.out.println("Your password is tai duan le.");
			}
			else {
				for(int j=0;j<s.length();j++) {
					char a = s.charAt(j);
					if(a=='.' || (a>='0' && a<='9') || (a>='a' && a<='z')) {
						
						if(a>='0' && a<='9') {
							cntn++;
						}
						else if(a>='a' && a<='z'){
							cntw++;
						}
					}
					
					else {
						System.out.println("Your password is tai luan le.");
						continue OUT;
					}
					
					
				}
				if(cntn==0) {
					System.out.println("Your password needs shu zi.");
					
				}
				if(cntw==0) {
					System.out.println("Your password needs zi mu.");
					
				}
				if(cntn!=0 && cntw!=0) {
					System.out.println("Your password is wan mei.");
				}
				cntn = 0;
				cntw = 0;
			}
				
		}
			
	}

}

 结果:

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值