问题描述:
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
代码:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String s = sc.nextLine();
// 计算每种字母的个数
int[] count = new int[26];
for(int i=0;i<s.length();i++) {
if(s.charAt(i)>='A' && s.charAt(i)<='Z') {
count[s.charAt(i)-'A']++;
}
if(s.charAt(i)>='a' && s.charAt(i)<='z') {
count[s.charAt(i)-'a']++;
}
}
// 找最大数及其索引
int max = 0;
int index = 0;
for(int i=0;i<count.length;i++) {
if(count[i]>max) {
max=count[i];
index=i;
}
}
System.out.println((char)(index+'a')+" "+max);
}
}
结果: