02-线性结构4 Pop Sequence

给定一个最大容量为M的栈,按1到N的顺序推入数字,然后随机弹出。程序需判断一系列给定的弹出序列是否可能。输入包含测试用例,每个用例包含M、N和K(弹出序列数量),然后列出K个弹出序列。输出为每个序列是否可能的结果。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

问题

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

解答

#include <iostream>
#include <stack>
using namespace std;

bool stackPermutation(int B[], int n, unsigned size)
{
    stack<int> S;
    for (int k = 0, i = 1; k < n; ++k)
    {
        while (S.empty() or B[k] != S.top())
        {
            if (i > n)
                return false;
            S.push(i++);
            if (S.size() > size)
                return false;
        }
        // cout << S.top() << " ";
        S.pop();
    }
    return true;
}

int main()
{
    int M, N, K;
    cin >> M >> N >> K;
    int *array = new int[N * K];
    for (int i = 0; i < K; ++i)
    {
        for (int j = 0; j < N; ++j)
        {
            cin >> array[i * N + j];
        }
    }
    for (int i = 0; i < K; ++i)
    {
        int *a = array + i * N;
        if (stackPermutation(a, N, M))
            cout << "Yes" << endl;
        else
            cout << "No" << endl;
    }
    delete[] array;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值