HDU - 4122 Alice's mooncake shop 单调队列

针对中秋节期间大量月饼订单,本文介绍了一个优化方案来减少制作成本。通过对不同时间点制作月饼的成本进行分析,并考虑月饼的存储时间和存储成本,利用单调队列算法实现了总成本的最小化。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4606    Accepted Submission(s): 1226


 

Problem Description

The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 


The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.

 

 

Input

The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.

 

 

Output

You should output one line for each test case: the minimum cost. 

 

 

Sample Input

 

1 10

Jan 1 2000 9 10

5 2

20 20 20 10 10 8 7 9 5 10

0 0

 

 

Sample Output

 

70

Hint

“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.

 

 

Source

2011 Asia Fuzhou Regional Contest

 

 

Recommend

lcy


题解

给出每个时刻制作月饼的花费,给出许多请求,请求是被认为某时刻需要提供多少月饼,而月饼拥有保质期,和保存一小时的花费.

现在要求满足全部请求的总花费最小。

对于某个时刻的请求来说 mincost = {cost[i] + (h-i)*s | h-t<=i<=h} h是请求需要提交的时刻,T是保质期(可以提前多久做)

很显然的单调队列用法


代码

/*
    给出每个时刻制作月饼的花费,给出许多请求,请求是被认为某时刻需要提供多少月饼,而月饼拥有保质期,和保存一小时的花费.
    现在要求满足全部请求的总花费最小。
    对于某个时刻的请求来说 mincost = {cost[i] + (h-i)*s | h-t<=i<=h} h是请求需要提交的时刻,T是保质期(可以提前多久做)
*/
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
int n,m,day,year,H,R,S,T,order[maxn];
char mouth[10];
map<string,int> ma;
deque<pair<int,int> > qu;
int f[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
void init() {
    ma["Jan"] = 1;ma["Feb"] = 2;ma["Mar"] = 3;ma["Apr"] = 4;
    ma["May"] = 5;ma["Jun"] = 6;ma["Jul"] = 7;ma["Aug"] = 8;
    ma["Sep"] = 9;ma["Oct"] = 10;ma["Nov"] = 11;ma["Dec"] = 12;
    
}
inline bool run(int x) {
    return (x % 4 == 0 && x % 100 !=0) || (x % 400 == 0);
}
inline int gethour() {
    int ans = 0;
    ans += H;
    ans += (day-1)*24;
    int mou = ma[mouth];
    for(int i=1;i<mou;i++) {
        if(i == 2 && run(year)) 
            ans += 29 * 24;
        else ans += f[i]*24;
    }
    for(int i=2000;i<year;i++) {
        if(run(i)) ans += 366 * 24;
        else ans += 365 * 24;
    }
    //printf("%d\n",ans);
    return ans;
}
int main() 
{
    init();
    while(~scanf("%d%d",&n,&m),n+m) {
        qu.clear();
        memset(order,0,sizeof(order));
        for(int i=1;i<=n;i++) {
            scanf("%s%d%d%d%d",mouth,&day,&year,&H,&R);
            order[gethour()] += R;
        }
        ll res = 0;
        scanf("%d%d",&T,&S);
        for(int i=0,x;i<m;i++) {
            scanf("%d",&x);
            while(!qu.empty() && qu.back().second + (i-qu.back().first)*S >= x) qu.pop_back();
            qu.push_back(make_pair(i,x));
            while(!qu.empty() && qu.front().first + T < i) qu.pop_front();
            if(order[i]) {
                res += order[i] * (qu.front().second + (i - qu.front().first)*S);
            }
        }
        printf("%lld\n",res);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值