HDU Problem - 1789 Doing Homework again【贪心】

本文介绍了一个优化算法,用于解决学生Ignatius面对多门课程作业时如何合理安排完成顺序的问题,以最小化因逾期而产生的分数损失。通过按作业截止日期升序排列,并采用特定策略选择优先完成的作业,该算法能有效降低总扣分。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11352    Accepted Submission(s): 6672


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 
WA了无数次之后终于过了。我的思路是按照交作业的最后期限进行升序排列,从第一个开始,每次找最大的加入dn中,如果在最后期限的那天有多个,把最大的加入到dn,其他的如果大于dn中最小的,就把他加入dn,把最小算作扣分,否则对其进行扣分。每次查找时对dn进行排序,好找他的最小值进行替换,这样就可以做到将最大的做完,把较小的加上去。查了无数次bug,对拍了好多次,终于AC了,现在我坚信细心的重要性了。
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1010
#define MAX(a, b)   ((a > b)? a: b)
#define MIN(a, b)   ((a < b)? a: b)
using namespace std;
const int INF = 1e8;

struct node{
    int del, red;
}data[MAX_N];

bool cmp(node x, node y) {
    if (x.del == y.del) return x.red > y.red;
    return x.del < y.del;
}
int dn[MAX_N];
void init() {
    for (int i = 0; i < MAX_N; i++) {
        dn[i] = INF;
    }
}
int main() {
    int t, n;
   // freopen("data.txt", "r", stdin);
    //freopen("1.txt", "w", stdout);
    scanf("%d", &t);
    while (t--) {
        init();
        scanf("%d", &n);
       // printf("%d ", n);
        int ans = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d", &data[i].del);
           // printf("%d ", data[i].del);
        }
        for (int i = 0; i < n; i++) {
            scanf("%d", &data[i].red);
        //    printf("%d ", data[i].red);
        }
        sort(data, data + n, cmp);
        int cnt = 0; //用作天数计数 
        int cnt3 = 0;
        for (int i = 0; i < n; i++) {
        	//如果期限为0,加上 
            if (data[i].del == 0) {
                ans += data[i].red;
                continue;
            }
            int k = i;
            bool flag = true;
            //如果没有到data[i]规定的最后期限,dn放0 
            while (++cnt < data[i].del) {
            	dn[cnt3++] = 0;
			}
            while (data[i].del == data[k].del) {
            	if (k == n) break;
                sort(dn, dn + cnt3);
                if (data[k].del >= cnt && flag) {
                    dn[cnt3++] = data[k].red;
                    flag = false;
                }
                else {
                    if (data[k].red > dn[0]) {
                        ans += dn[0];
                        dn[0] = data[k].red;
                    }
                    else ans += data[k].red;
                }
                k++;
            }
            i = k - 1;
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值