<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[lucien的博客]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/lucien_cc</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; lucien_cc]]></copyright><item><title><![CDATA[pluto list]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/40679443</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/40679443</guid><author>lucien_cc</author><pubDate>Sat, 01 Nov 2014 12:36:57 +0800</pubDate><description><![CDATA[pluto source code analysis

        01.Source Code Overview(03)
        02.Function Invoke(04)
        03.Main Structure(05)
        04.System Initation(06)
        05.Kernel Interface(07)
    ]]></description><category></category></item><item><title><![CDATA[Linux网络地址转换NAT源码分析]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/19343439</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/19343439</guid><author>lucien_cc</author><pubDate>Mon, 17 Feb 2014 17:14:15 +0800</pubDate><description><![CDATA[http://wenku.baidu.com/view/780db87831b765ce05081418.html]]></description><category></category></item><item><title><![CDATA[Netfilter源代码分析详解]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/19338379</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/19338379</guid><author>lucien_cc</author><pubDate>Mon, 17 Feb 2014 15:37:07 +0800</pubDate><description><![CDATA[http://wenku.baidu.com/view/fc3fc56c561252d380eb6ed9.html]]></description><category></category></item><item><title><![CDATA[linux conntrack]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/19010691</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/19010691</guid><author>lucien_cc</author><pubDate>Sun, 09 Feb 2014 16:12:08 +0800</pubDate><description><![CDATA[http://staff.ustc.edu.cn/~james/linux/nat.html
http://blog.youkuaiyun.com/efan_linux/article/details/4604362
http://blog.youkuaiyun.com/dog250/article/details/9732185]]></description><category></category></item><item><title><![CDATA[使用openssl命令剖析RSA私钥文件格式]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/18407451</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/18407451</guid><author>lucien_cc</author><pubDate>Fri, 17 Jan 2014 14:54:15 +0800</pubDate><description><![CDATA[Openssl提供了强大证书功能，生成密钥对、证书，颁发证书、生成crl、验证证书、销毁证书等。本文将j介绍如何利用openssl的命令分析RSA私钥文件格式，同时也将简单介绍几种常见的私钥文件格式。
 
1 生成私钥文件
openssl有多种方法生成私钥：

genrsa生成RSA密钥。req在生成req证书请求时同时产生密钥。genpkey除了可以生成RSA密钥外，还可以生成DSA、]]></description><category></category></item><item><title><![CDATA[TCP拥塞控制算法内核实现剖析]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/18186857</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/18186857</guid><author>lucien_cc</author><pubDate>Sun, 12 Jan 2014 18:10:49 +0800</pubDate><description><![CDATA[http://blog.youkuaiyun.com/zhangskd/article/details/7084782]]></description><category></category></item><item><title><![CDATA[route add]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/17924047</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/17924047</guid><author>lucien_cc</author><pubDate>Mon, 06 Jan 2014 18:14:51 +0800</pubDate><description><![CDATA[http://tinc-vpn.org/documentation/Routes.html]]></description><category></category></item><item><title><![CDATA[train tessseract]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/17682121</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/17682121</guid><author>lucien_cc</author><pubDate>Mon, 30 Dec 2013 15:36:08 +0800</pubDate><description><![CDATA[http://www.cedricve.me/2013/04/12/how-to-train-tesseract/


http://blog.youkuaiyun.com/firehood_/article/details/8433077]]></description><category></category></item><item><title><![CDATA[freebsd, openbsd, netbsd]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/16919785</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/16919785</guid><author>lucien_cc</author><pubDate>Sun, 24 Nov 2013 14:47:26 +0800</pubDate><description><![CDATA[http://www.360doc.com/content/10/1228/23/3688062_82184475.shtml]]></description><category></category></item><item><title><![CDATA[Linux,Solaris和FreeBSD三大操作系统的比较]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/16919609</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/16919609</guid><author>lucien_cc</author><pubDate>Sun, 24 Nov 2013 14:34:32 +0800</pubDate><description><![CDATA[kernel: http://blog.youkuaiyun.com/lm2302293/article/details/6787350
comformance: http://school.cfan.com.cn/system/unix/2009-06-14/1244971964d213942.shtml]]></description><category></category></item><item><title><![CDATA[ikev2 学习]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/16856009</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/16856009</guid><author>lucien_cc</author><pubDate>Thu, 21 Nov 2013 09:52:03 +0800</pubDate><description><![CDATA[http://pic.dhe.ibm.com/infocenter/zos/v1r12/index.jsp?topic=%2Fcom.ibm.zos.r12.hald001%2Finitex.htm]]></description><category></category></item><item><title><![CDATA[openstack install]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/16845719</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/16845719</guid><author>lucien_cc</author><pubDate>Wed, 20 Nov 2013 16:09:32 +0800</pubDate><description><![CDATA[这个是自动化安装手册   https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Getting_Started_Guide/index.html
手工安装手册 https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3]]></description><category></category></item><item><title><![CDATA[Open vSwitch使用笔记]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/16787161</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/16787161</guid><author>lucien_cc</author><pubDate>Sun, 17 Nov 2013 23:37:07 +0800</pubDate><description><![CDATA[1. Open
vSwitch介绍 
1.1虚拟化网络架构图
1.2 Open
vSwitch功能介绍
2. 安装，启动，关闭 
2.1 源码安装
2.2 apt安装
2.3 启动脚本
2.4 关闭脚本
2.5 virsh启动
3. 配置，使用 
3.1流规则 
3.2VLAN
3.3 sflow
3.4接入物理机 
4. 遇到的问题 
4.1找不到opevswi]]></description><category></category></item><item><title><![CDATA[netlink 介绍]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/14088485</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/14088485</guid><author>lucien_cc</author><pubDate>Sat, 02 Nov 2013 21:25:17 +0800</pubDate><description><![CDATA[http://os.it168.com/a2009/0430/993/000000993531.shtml
http://zh.wikipedia.org/wiki/Netlink]]></description><category></category></item><item><title><![CDATA[IPSec-Tools配置]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/13280439</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/13280439</guid><author>lucien_cc</author><pubDate>Sun, 27 Oct 2013 23:44:46 +0800</pubDate><description><![CDATA[http://blog.youkuaiyun.com/zt698/article/details/4811604

1       介绍

从Linux 2.6内核开始，内核就自身带有IPSec模块，配合IPSec-Tools，能很好的实现Linux的IPSec功能。
IPSec-Tools主要包含libipsec、setkey、racoon和racoonctl这4个模块，setkey主要用于配置S]]></description><category></category></item><item><title><![CDATA[linux kernel 3.6版本网络子系统新特性 - TCP]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/12967407</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/12967407</guid><author>lucien_cc</author><pubDate>Wed, 23 Oct 2013 10:01:54 +0800</pubDate><description><![CDATA[一，TCP fast open 客户端实现

     这个特性是google提出并主导开发的。实现的原理是对于客户端允许发送syn请求时携带数据， 对于服务器端收到带有数据的syn请求后，可以立刻提交给用户层，并发送ack， 这样节省一个RTT时间。  
     这个特性对于短连接的业务类型比较有很大的帮助，据测试结果有4%~41%的性能提升。
    这个特性需要客户端和服务器端的o]]></description><category></category></item><item><title><![CDATA[sctp rfc相关文档]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/12688781</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/12688781</guid><author>lucien_cc</author><pubDate>Sun, 13 Oct 2013 22:36:36 +0800</pubDate><description><![CDATA[RFC 2960 – Stream Control Transmission Protocol
RFC 3257 - SCTP Applicability Statement
RFC 3286 - An introduction to SCTP
RFC 3309 – SCTP Checksum Change
RFC 3436 – Transport Layer Security over ]]></description><category></category></item><item><title><![CDATA[TCP协议经典rfc主题总结]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/12688599</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/12688599</guid><author>lucien_cc</author><pubDate>Sun, 13 Oct 2013 22:31:57 +0800</pubDate><description><![CDATA[Richard Stevens的书虽好，但是他所要表达的是让你知其然。对于想精通tcp的同学来说，光知其然是远远不够的，你还需要更多的时间去了解其所以然，而翻阅rfc文档就是一种最好的方式，这样你就明白tcp为何这么设计了。
这里总结了一下tcp核心主题对应的rfc文档，方便自己和大家查阅。:)






rfc序列号

主题

内容描述



793

TC]]></description><category></category></item><item><title><![CDATA[IPv6相关RFC]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/12688477</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/12688477</guid><author>lucien_cc</author><pubDate>Sun, 13 Oct 2013 22:29:27 +0800</pubDate><description><![CDATA[IPv6 Spec


RFC 2460 : Internet Protocol, Version 6 (IPv6) Specification


RFC 5095: Deprecation of Type 0 Routing Headers in IPv6


RFC 5722 (更新RFC 2460): Handling of Overlapping IPv6 Fragme]]></description><category></category></item><item><title><![CDATA[Linux实现的IEEE 802.1Q VLAN]]></title><link>https://blog.youkuaiyun.com/lucien_cc/article/details/12612855</link><guid>https://blog.youkuaiyun.com/lucien_cc/article/details/12612855</guid><author>lucien_cc</author><pubDate>Fri, 11 Oct 2013 10:52:46 +0800</pubDate><description><![CDATA[目录(?)[+]


第一部分：VLAN的核心概念
说起IEEE 802.1q，都知道是VLAN，说起VLAN，基本上也没有盲区，网络基础。然而说到配置，基本所有人都能顺口溜一样说出Cisco或者H3C设备的配置命令，对于Linux的VLAN配置却存在大量的疑问。这些疑问之所以存在我觉得有两点原因：
1.对VLAN的本质还是没有理解。
不管你的Cisco/H3C命令敲得再熟练，如果看不]]></description><category></category></item></channel></rss>