Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
这道题目考查高精度乘法的计算。
(1)用到BigDecimal类型。该类可保存任意精度的实数,并可表示成指数形式、非指数形式。
(2)用BigDecimal内置的stripTrailingZeros函数解决“结尾不能出现零”的问题。
(3)用substring实现(.00245)的形式,substring是java中截取字符串的一个方法。
import java.math.BigInteger;
import java.math.BigDecimal;
import java.util.Scanner;
import java.io.*;
public class Main {
/**
* @param args
*/
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);
while (input.hasNext())
{
int n;
BigDecimal a = input.nextBigDecimal(); //读入一个BigDecimal
n = input.nextInt();
a = a.pow(n); // 返回其值为 (thisn) 的 BigDecimal,准确计算该幂,使其具有无限精度。
a = a.stripTrailingZeros();
/*public BigDecimal stripTrailingZeros
* 返回数值上等于此小数,但表示形式溢出所有尾部0的BigDecimal
* 1.22222300000 用过之后为1.222223 类型还是BigDeciaml类型
*/
String str = a.toPlainString();
/*
* 注意toPlainString()和toString()的区别
* 对于:BigDecimal s; s = (0.4321^20)
* String str = s.toPlainString();
* System.out.println(str);
* 输出:0.0000000514855464107。。。。。01
*
*若String str = s.toString();
*输出为: 5.14855464107。。。。01E-8
*/
if (str.startsWith("0.")) //以什么开始
{
str = str.substring(1);
/*substring是java中截取字符串的一个方法
* 有两种传参方式
* 一种是:public String substring(int deginindex)
* 返回一个新的字符串,它是此字符串的一个子串,该字串从指定索引处的字符开始直到字符串末尾
* 另一种是public String substring(int deginindex,int endindex)
* 返回一个新字符串,也是它的一个子串。该字串从beginindex处开始
* 直到索引到endindex-1处的字符。因此该字符串的长度为endindex-beginindex
*
*
* substr
* 该方法用于返回一个从指定位置开始的指定长度的子字符串
*substr(start,length);
*/
}
System.out.println(str);
}
}
}