LightOJ 1047 Neighbor House (DP 数字三角形变形)

Description

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and B are the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

 

4

13 23 12

77 36 64

44 89 76

31 78 45

 

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

题目大意:相邻行不能取同一列的数字,从上往下路径最大权值和问题。


解题思路:只有三列,每步有两次选择,dp[i][j]表示到第a[i][j]步的最小数字累加和,起点处分三条路,最后选出和最小的一条路。

#include<cstdio>  
#include<cstring>  
#include<stack>  
#include<algorithm>  
using namespace std;  
#define LL long long  
int shu[25][5],dp[25][5],s;  
int main()  
{  
    int t;scanf("%d",&t);  
    for (int ca=1;ca<=t;ca++)  
    {  
        int n;scanf("%d",&n);  
        for (int i=1;i<=n;i++)  
        scanf("%d%d%d",&shu[i][1],&shu[i][2],&shu[i][3]);  
        dp[0][0]=dp[0][1]=dp[0][2]=dp[0][3]=0;  
        for (int i=1;i<=n;i++)  
        {  
            dp[i][1]=min(dp[i-1][2],dp[i-1][3])+shu[i][1];  
            dp[i][2]=min(dp[i-1][1],dp[i-1][3])+shu[i][2];  
            dp[i][3]=min(dp[i-1][2],dp[i-1][1])+shu[i][3];  
        }  
        printf("Case %d: %d\n",ca,min(min(dp[n][1],dp[n][2]),dp[n][3]));  
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值