Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 118758 Accepted Submission(s): 46550
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
解题思路:题目意思就是叫我们输出每一组样例中出现次数最多的一种颜色
#include<stdio.h>
#include<map>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
map <string,int> a;
int main()
{
int n;
int maxx=-1;
string s,b;
while(cin>>n&&n!=0)
{
a.clear();
maxx=-1;
for(int i=0;i<n;i++)
{
cin>>s;
a[s]++;
}
map<string,int>::iterator it;
for(it=a.begin();it!=a.end();it++)
{
if(maxx<(it->second))
{
maxx=it->second;
b=it->first;
}
}
cout<<b<<endl;
}
return 0;
}