Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 36781 Accepted Submission(s): 16202
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题意:输入一个数字,输出一个素数环,要求每个相邻的数字和为质数,第一个数固定为1
代码如下:
#include <stdio.h>
#include <string.h>
int ans[25];
int a[25];
int n;
int f[35];
void fun()
{
int i,j;
memset(f,0,sizeof(f));
for(i=2;i<=30;i++)
{
for(j=2*i;j<=30;j+=i)
f[j]=1;
}
}
void dfs(int t)
{
int i;
if(t>n)
{
if(f[ans[n]+1]==0)
{
printf("1");
for(i=2;i<=n;i++)
printf(" %d",ans[i]);
putchar('\n');
}
return ;
}
for(i=2;i<=n;i++)
{
if(a[i]==0 && f[ans[t-1]+i]==0)
{
a[i]=1;
ans[t]=i;
dfs(t+1);
a[i]=0;
}
}
}
int main()
{
int T=0;
fun();
while(~scanf("%d",&n))
{
T++;
printf("Case %d:\n",T);
memset(a,0,sizeof(a));
a[1]=1;
ans[1]=1;
dfs(2);
putchar('\n');
}
return 0;
}