hdu 5670 Machine(模拟)

本文介绍了一种灯泡颜色变化的算法实现,灯泡有红、绿、蓝三种颜色,通过按钮触发颜色的变化,右侧灯泡每秒变化一次,左侧灯泡每隔三秒变化一次,文章提供了完整的C语言代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


Description

There is a machine with  m (2\leq m\leq 30)  coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 
For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed  n (1\leq n< {2}^{63})  times?
 

Input

There are multiple test cases. The first line of input contains an integer  T (1\leq T\leq 15)  indicating the number of test cases. For each test case: 

The only line contains two integers  m (2\leq m\leq 30)  and  n (1\leq n< {2}^{63}) .
 

Output

For each test case, output the colour of m bulbs from left to right. 
R indicates red. G indicates green. B indicates blue.
 

Sample Input

    
    
2 3 1 2 3
 

Sample Output

    
    
RRG GR
分析:

可能是我语文学的不好吧,比赛时没有理解题意,等我理解了比赛也结束了,

题目是说灯有红蓝绿三种颜色转换,右边的一秒变一次,左边的3秒变一次,

依次向左推,输出最后灯的颜色!

#include<stdio.h>
#include<string.h>
int main()
{
    long long  n;
    int i,j,t,m;
    char a[35];
    scanf("%d",&t);
    while(t--)
    {
        memset(a,'R',sizeof(a));
        scanf("%d%I64d",&m,&n);
        long long  c=3,b=1;
        for(i=m-1; i>=0; i--)
        {
            if( (n%c)/b==0)
                a[i]='R';
            if((n%c)/b==1)
                a[i]='G';
            if((n%c)/b==2)
                a[i]='B';
            c*=3;
            b*=3;
        }
        a[m]='\0';
        printf("%s\n",a);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值