AYIT606第四周周六赛 C - Audiophobia 音频恐惧症(dp)

本文探讨了在污染严重的城市环境中找到最舒适的路径以避免高分贝噪音的问题,通过算法解决给定两个交叉路口间最小声强容忍度的计算。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

                                     C - Audiophobia


  Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in this contest. But we apprehend that many of your descendants may not have this luxury. For, as you
know, we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in the environment and in society and our lack of consciousness is simply aggravating the situation.
However, for the time being, we will consider only one type of pollution - the sound pollution. The
loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130decibels or higher is considered painful. The intensity level of normal conversation is 6065 decibels andthat of heavy traffic is 7080 decibels.
  Consider the following city map where the edges refer to streets and the nodes refer to crossings.
The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.To get from crossing A to crossing G you may follow the following path: A-C-F-G. In that case
you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A-B-E-G,
A-B-D-G and A-C-F-D-G you must tolerate respectively 90, 120 and 80 decibels of sound intensity.
There are other paths, too. However, it is clear that A-C-F-D-G is the most comfortable path since.it does not demand you to tolerate more than 80 decibels.In this problem, given a city map you are required to determine the minimum sound intensity levelyou must be able to tolerate in order to get from a given crossing to another.
Input

The input may contain multiple test cases.
The first line of each test case contains three integers C(≤ 100), S(≤ 1000) and Q(≤ 10000) where
C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to
C), S represents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers: c1, c2 and d indicating that the average sound
intensity level on the street connecting the crossings c1 and c2 (c1 ̸= c2) is d decibels.
Each of the next Q lines contains two integers c1 and c2 (c1 ̸= c2) asking for the minimum sound
intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C, S and Q.
Output
For each test case in the input first output the test case number (starting from 1) as shown in the
sample output. Then for each query in the input print a line giving the minimum sound intensity level
(in decibels) you must be able to tolerate in order to get from the first to the second crossing in the
query. If there exists no path between them just print the line “no path”.
Print a blank line between two consecutive test cases.
Sample Input


7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0


Sample Output


Case #1
80
60
60
Case #2
40
no path
80


分析:

采用提前打表的方法,可以避免程序提交时的超时问题,然后用数组存放遍历出的所有可能出现的情况,主函数中调用输出即可!

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int m,n,ma,flag,t[1100][1100];
void dfs()
{
    int i,j,k;
    for(k=1;k<=m;k++)
    for(i=1;i<=m;i++)
        for(j=1;j<=m;j++)
            t[i][j]=min(t[i][j],max(t[i][k],t[k][j]));
}
int main()
{
    int i,j,a,b,c,f=0,k;
    while(scanf("%d%d%d",&m,&n,&k)&&m+n+k)
    {


        memset(t,INF,sizeof(t));
        for(i=0; i<n; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            t[a][b]=t[b][a]=c;
        }
         dfs();
          if(f)
            printf("\n");
        printf("Case #%d\n",++f);
        for(i=0; i<k; i++)
        {
            scanf("%d%d",&a,&b);

            if(t[a][b]!=INF)
                printf("%d\n",t[a][b]);
            else
                printf("no path\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值