POJ 3623 Best Cow Line

Best Cow Line, Gold
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4024 Accepted: 1487

Description

FJ is about to take his N (1 ≤ N ≤ 30,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

USACO 2007 December Gold



首先想到的是从首尾选择最小的一个 这个是显然的
当首尾相同时 可以向内找到第一个不同的 当前面小于或等于时 先取前面的 否则取后面的

话说我咋写了这么长? Orz六行秒杀的XGH大神
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int q[3333],top;
int head,tail,s[3333];
int a,b,c,m;
char chin;
int find(int x,int y)
{
    while(s[x]==s[y]&&x<=y){x++;y--;}
    if(x>y)return 0;
    if(s[x]<=s[y])return 0;
    return 1;
}

void print()
{
    int k=0,a;
    for(a=1;a<=top;a++)
    {
        printf("%c",(char)(q[a]+'A'));
        k++;
        if(k==80)
        {
            printf("\n");
            k=0;
        }
    }
    if(k!=0)printf("\n");
}

int main()
{
    scanf("%d\n",&m);
    for(a=1;a<=m;a++)
    {
        scanf("%c\n",&chin);
        s[a]=chin-'A';
    }
    head=1;tail=m;
    while(head<=tail)
    {
        if(s[head]<s[tail])
        {
            top++;
            q[top]=s[head];
            head++;
        }
        else
        if(s[head]>s[tail])
        {
            top++;
            q[top]=s[tail];
            tail--;
        }
        else
        {
            int direct=find(head,tail);
            if(direct==0)
            {
                top++;
                q[top]=s[head];
                head++;
            }
            else 
            {
                top++;
                q[top]=s[tail];
                tail--;
            }
        }
    }
    print();
    return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值