Sudoku

描述
Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.
这里写图片描述

输入
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

输出
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

样例输入
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

样例输出
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

经典数独问题,使用dfs来做,遍历大九宫格,检查小九宫格。
代码如下:

#include<iostream>
#include<memory.h>
using namespace std;
char map[10][10];
int pos[90][2];//记录未填入数的位置 
bool row[10][10],list[10][10];
int k;
bool dfs(int x);
bool check(int v,int num);
int main()
{
    int t,i,j;
    cin>>t;
    while(t--)
    {
        memset(row,false,sizeof(row));
        memset(list,false,sizeof(list));
        k=0;
        for(i=0;i<9;i++)
        {
            for(j=0;j<9;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='0')
                {
                    pos[k][0]=i;
                    pos[k++][1]=j;
                }
                else
                {
                    row[i][map[i][j]-'0']=true;//标记第i行某数以用 
                    list[j][map[i][j]-'0']=true;//标记第j列某数以用 
                }
            }

        }
        dfs(0);

            for(i=0;i<9;i++)
        {
            for(j=0;j<9;j++)
            cout<<map[i][j];
            cout<<endl;
        }
        }

    return 0;
}
bool dfs(int v)
{
    if(v==k)//所有空均已填入 
    return true;

    for(int i=1;i<=9;i++)
    {
        if(!row[pos[v][0]][i]&&!list[pos[v][1]][i]&&check(v,i))
        {
            map[pos[v][0]][pos[v][1]]=i+'0';
            row[pos[v][0]][i]=true;
            list[pos[v][1]][i]=true;
            if(dfs(v+1))
            {
                return true;
            }
            map[pos[v][0]][pos[v][1]]='0';
            row[pos[v][0]][i]=false;
            list[pos[v][1]][i]=false;

        }

    }
    return false;
}
bool check(int v,int num)//判断小九宫格是否重复 
{
    int n=pos[v][0]/3*3;
    int m=pos[v][1]/3*3;

    for(int i=n;i<n+3;i++)
    for(int j=m;j<m+3;j++)
    {
        if(map[i][j]==num+'0')
    return false;
    }


    return true;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值