整数解
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20680 Accepted Submission(s): 7238
Problem Description
有二个整数,它们加起来等于某个整数,乘起来又等于另一个整数,它们到底是真还是假,也就是这种整数到底存不存在,实在有点吃不准,你能快速回答吗?看来只能通过编程。
例如:
x + y = 9,x * y = 15 ? 找不到这样的整数x和y
1+4=5,1*4=4,所以,加起来等于5,乘起来等于4的二个整数为1和4
7+(-8)=-1,7*(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8
例如:
x + y = 9,x * y = 15 ? 找不到这样的整数x和y
1+4=5,1*4=4,所以,加起来等于5,乘起来等于4的二个整数为1和4
7+(-8)=-1,7*(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8
Input
输入数据为成对出现的整数n,m(-10000<n,m<10000),它们分别表示整数的和与积,如果两者都为0,则输入结束。
Output
只需要对于每个n和m,输出“Yes”或者“No”,明确有还是没有这种整数就行了。
Sample Input
9 15 5 4 1 -56 0 0
Sample Output
No Yes Yes
Author
qianneng
Source
Recommend
#include<stdio.h>
int main()
{
int n,m,i,j,p;
while(scanf("%d%d",&n,&m)!=EOF&&(m!=0||n!=0))
{
j=0;
if(m<0)
{
m=-m;
j=1;
}
for(i=-m;i<=m;i++)
{
p=0;
if(i==0)
continue;
else if(m%i!=0)
continue;
else
{
if((m/i+i==n&&j==0)||(-m/i+i==n&&j==1))
{
p=1;
break;
}
}
}
if(p)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
//无符号数怎么来确定他的循环限制条件 如果用-10000到10000for循环应该会超时