1030 Travel Plan (30 分)--PAT甲级

本文深入探讨了如何使用Dijkstra算法结合深度优先搜索(DFS)来寻找两点间花费最少的最短路径。通过实例讲解了算法的具体实现过程,包括初始化距离矩阵、成本矩阵,运用Dijkstra算法更新最短路径,并通过DFS遍历所有可能路径找到最小成本路径。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1030 Travel Plan (30 分)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.
Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

求花费最少的最短路径。
直接dijkstra+dfs吧,同样是30分,1111 Online Map (30 分)就比这道麻烦多了。

#include <iostream>
#include<cstdio>
#include<cmath>
#include <algorithm>
#include<vector>
using namespace std;
const int maxn = 505;
const int inf = 0x3fffffff;
int n,first,last;
int dist[maxn][maxn];
int cost[maxn][maxn];
int d[maxn];
bool visit[maxn];
vector<vector<int> >pre;
vector<int>path;
int mincost=inf;

void dijkstra(int s){
    fill(d,d+n,inf);
    d[s]=0;
    for(int i=0;i<n;i++){
        int u=-1,MIN=inf;
        for(int j=0;j<n;j++){
            if(visit[j]==false && d[j]<MIN){
                MIN=d[j];
                u=j;
            }
        }
        if(u==-1) return;
        visit[u]=true;
        for(int v=0;v<n;v++){
            if(visit[v]==false && dist[u][v]!=0){
                if(dist[u][v]+d[u]<d[v]){
                    d[v]=dist[u][v]+d[u];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(dist[u][v]+d[u]==d[v]){
                    pre[v].push_back(u);
                }
            }
        }
    }
}

void dfs(int v,vector<int>temp,int cst){
    temp.push_back(v);
    if(v==first){
        if(cst<mincost){
            mincost=cst;
            path=temp;
        }
        return;
    }
    else{
        for(int i=0;i<pre[v].size();i++){
            dfs(pre[v][i],temp,cst+cost[pre[v][i]][v]);
        }
    }
}

int main()
{
    int m;
    scanf("%d %d %d %d",&n,&m,&first,&last);
    pre.resize(n);
    for(int i=0;i<m;i++){
        int a,b,c,d;
        scanf("%d %d %d %d",&a,&b,&c,&d);
        dist[a][b]=c;
        dist[b][a]=c;
        cost[a][b]=d;
        cost[b][a]=d;
    }
    dijkstra(first);
    vector<int>t;
    dfs(last,t,0);
    for(int i=path.size()-1;i>=0;i--){
        printf("%d ",path[i]);
    }
    printf("%d %d\n",d[last],mincost);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值