poj1573--Robot Motion

本文介绍了一种通过模拟机器人在给定指令集的网格中移动的方法来解决机器人导航问题。重点在于判断机器人是否能成功退出网格,或是陷入无限循环。通过记录已访问的位置并追踪移动步数,该算法能有效找出解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题意: 给你一个nXm的矩阵 里面放了ESWN四个字母分表代表东南西北然后给你一个位置 代表第一列(最上面一列)的第k个位置,然后要求求出机器人根据东南西北的指令最终会在第几步走出地图或者在第几步进入一个一共几步的循环


原题:

Robot Motion
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13477 Accepted: 6509

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

很简单的模拟 看代码应该就能看懂 只要模拟机器人一直走就好,开一个状态数组记录位置是否走过 

题很水不说太多 直接上代码:

#include <iostream>
#include <string.h>

using namespace std;

int main()
{
    int n,m,po,pox,poy,step;
    bool flag;
    char rmap[100][100];
    bool vis[100][100];
    while(cin>>n>>m>>po&&(n!=0||m!=0||po!=0))
    {
        memset(vis,0,sizeof(vis));
        flag = false;
        pox = po-1;
        poy = 0;
        step = 0;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>rmap[i][j];
        while(pox>=0&&poy>=0&&pox<m&&poy<n){
            if(!vis[poy][pox]){
                vis[poy][pox] = true;
                step++;
                if(rmap[poy][pox]=='W'){
                    pox--;
                }else if(rmap[poy][pox]=='E'){
                    pox++;
                }else if(rmap[poy][pox]=='S'){
                    poy++;
                }else if(rmap[poy][pox]=='N'){
                    poy--;
                }
            }else{
                vis[poy][pox] = false;
                flag = true;
                break;
            }
        }
        if(flag){
            pox = po-1;
            poy = 0;
            int count = 0;
            while(vis[poy][pox]){
                count++;
                if(rmap[poy][pox]=='W'){
                    pox--;
                }else if(rmap[poy][pox]=='E'){
                    pox++;
                }else if(rmap[poy][pox]=='S'){
                    poy++;
                }else if(rmap[poy][pox]=='N'){
                    poy--;
                }
            }
            cout<<count<<" step(s) before a loop of "<<step-count<<" step(s)"<<endl;
        }else{
            cout<<step<<" step(s) to exit"<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值