HDU 1907 - John(反向Nim博弈)

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 6015    Accepted Submission(s): 3497


 

Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
 

 

 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
 

 

 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
 

 

 

Sample Input

 

2

3

3 5 1

1

1

 

 

Sample Output

 

John

Brother

 

 

Source

Southeastern Europe 2007

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1913 1908 1914 1915 1909 

 

 

Statistic | Submit | Discuss | Note

 

题目的意思还是常规的nim博弈,区别是,这道题里取走最后一块石子的是败方。

如果按照常规的思路:异或和 sum != 0 时,先手必胜,后手必败。

我们能不能直接改一下结论,当  sum == 0 时,先手必败,后手必胜 呢?

答案是不可以的。因为有 3 1 1 1 (sum = = 1) 这样的样例存在。

我们再考虑一组样例, 3 2 1 1   (sum ==  2)

再考虑 3 2 2 1 (sum == 1) 3 2 2 2(sum == 2) 

发现,只要存在石子数 > 1 的石子堆时,直接套用反向结论是成立的,否则,需要特判。

#include<bits/stdc++.h>
using namespace std;
#define clr(a) memset(a, 0, sizeof(a))
#define line cout<<"-------------"<<endl

typedef long long ll;
const int maxn = 1e5 + 10;
const int MAXN = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1010;

int main(){
    int T;
    cin >> T;
    while(T--){
        int n, x, sum = 0;
        cin >> n;
        bool flag = false;
        for(int i=0; i<n; i++){
            scanf("%d", &x);
            sum ^= x;
            if(x > 1) flag = true;
        }
        if(flag){
            if(sum != 0) puts("John");
            else puts("Brother");
        }
        else{
            if(sum == 0) puts("John");
            else puts("Brother");
        }

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值