HDU - 1856 More is better(水+并查集)

点击打开题目链接

 

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 26832    Accepted Submission(s): 9611

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input

 
 
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

Sample Output

 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author

lxlcrystal@TJU

Source

Recommend

lcy   |   We have carefully selected several similar problems for you:   1232  1325  1879  1863  1875 

Statistic | Submit | Discuss | Note

并查集的裸题,题目大意:老师想让几个男同学来做一个项目,这些同学必须直接或间接的为朋友关系,求最多招几个男同学。

思路:这里集合的数量不确定,目的是求每个集合的元素数量,再加一个num数组记录每个集合的元素,初始为1,合并时相加即可。

试了一下不同输入方式的时间,第一行为cin加取消同步的情况,第二行为cin不加取消同步,第三种是scanf加万能头文件,第四种是scanf不加万能头文件。

可以看出第二种直接超时,最优的方案还是写文件名加scanf

附上AC代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn=10000000+5;
int par[maxn],num[maxn];
int n,f1,f2;
int maxd,mind,maxcnt;

void init()
{
    for(int i=0;i<maxn;i++)
        par[i]=i,num[i]=1;
}

int find(int a)
{
    if(a==par[a]) return a;
    return par[a]=find(par[a]);
}

void unite(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a==b)return ;
    par[a]=b;
    num[b]+=num[a];
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0){printf("1\n");continue;}
        init();
        maxd=INT_MIN;
        mind=INT_MAX;
        maxcnt=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&f1,&f2);
            maxd=max(maxd,max(f1,f2));
            mind=min(mind,min(f1,f2));
            unite(f1,f2);
        }
        for(int i=mind;i<=maxd;i++)
        {
                maxcnt=max(maxcnt,num[i]);
        }
        printf("%d\n",maxcnt);
    }
    return 0;
}

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值