UVA - 264 Count on Cantor

 Count on Cantor 

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

displaymath27

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to tex2html_wrap_inline29 and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4
 
 
根据输入的n,由于每行的分子分母之和固定,故判断其所在的行数,和在行中的位置,根据行的奇偶性得出分子和分母
 
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    while(cin >> n){
        int i = 1, sum = 0;
        do{
            sum += i;
            i++;
        }while(sum < n);

        int no = sum-n+1;
        int x, y;
        if(i%2==1){
            x = i-no;
            y = i-x;
        }
        else{
            y = i-no;
            x = i-y;
        }
        printf("TERM %d IS %d/%d\n", n, x, y);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值