poj1386 play on word 欧拉回路+并查集

本文介绍了一个有趣的单词拼接谜题,考古学家们需要解决这个谜题来打开秘密之门。文章详细描述了谜题的规则,并提供了一个示例程序,该程序使用并查集算法来判断是否能够按照特定规则排列所有单词。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10128 Accepted: 3465

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Source



没有并查集的话不能判断是不是联通。。。

code:
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
char a[1010];
int in[30],out[30],p[30],f[30];
int fabs(int a,int b)
{
if(a>b) return a-b;
else return b-a;
}
int findp(int x)
{
if(p[x]==x) return x;
else if(p[x]==0) return 0;
else return p[x]=findp(p[x]);
}
int main()
{
int t;
cin>>t;
int n;
while(t--)
{
memset(in,0,sizeof(in));
memset(out,0,sizeof(out));
memset(f,0,sizeof(f));
for(int i=1;i<=26;i++) p[i]=0;
cin>>n;
while(n--)
{
scanf("%s",&a);
int len=strlen(a);
in[a[0]-'a'+1]++;
out[a[len-1]-'a'+1]++;
f[a[0]-'a'+1]=1;
f[a[len-1]-'a'+1]=1;
int k1=a[0]-'a'+1;
int k2=a[len-1]-'a'+1;
if(findp(k1)==0)
{
if(findp(k2)==0)
{
p[k1]=min(k1,k2);
p[k2]=min(k1,k2);
}
else
{
p[k1]=k2;
}
}
else
{
if(findp(k2)==0)
{
p[k2]=k1;
}
else
{
p[k1]=min(p[k1],p[k2]);
p[k2]=p[k1];
}
}
}
int cnt=0;
for(int i=1;i<=26;i++)if(in[i]!=out[i])cnt+=fabs(in[i],out[i]);
int sum=0;
int tmp;
for(int i=1;i<=26;i++) if(f[i]==1) {tmp=findp(i);break;}
for(int i=1;i<=26;i++) if(f[i]==1) {if(findp(i)!=tmp) sum++;}
if(cnt<=2&&sum==0)cout<<"Ordering is possible."<<endl;
else cout<<"The door cannot be opened."<<endl;
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值