吃土豆

描述
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
输入
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出
For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
样例输出
242

解题思路:对于每一行,即求最大不连续子序列和求得每一行的最大不连续子序列和后,根据题目要求,对于矩阵的每一行都不连续,同样是一个最大不连续子序列和的问题。

AC代码如下:

 
#include <stdio.h>
int a[500], b[500];
int maxSubSeq(int a[], int size)
{
    if(size == 1)
        return a[0];
    if(size == 2)
        return a[0] > a[1] ? a[0] : a[1];
    int dpi, dpi_1, dpi_2;
    dpi_2 = a[0];
    dpi_1 = a[0] > a[1] ? a[0] : a[1];
    for(int i=2; i<size; i++)
    {
        int t = dpi_2 + a[i];
        dpi  = t > dpi_1 ? t : dpi_1;
        dpi_2 = dpi_1;
        dpi_1 = dpi;
    }
    return dpi;
}
int main()
{
    int m, n;
    while(scanf("%d %d", &m, &n) == 2)
    {
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                scanf("%d", &a[j]);
            }
            b[i] = maxSubSeq(a, n);
        }
        printf("%d\n", maxSubSeq(b, m));
    }
    return 0;
}        




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值