nyoj-113-字符串替换

字符串替换

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do
来源
水题比赛
上传者

hzyqazasdf

#include "iostream"
#include "cstring"
#include "cstdio"
using namespace std;
int main(int argc, char const *argv[])
{
    char a[1001];

    while(gets(a)!=NULL)
    {
        int i,len=0;
        len=strlen(a);
        for(i=0; i<len; i++)
        {
            if(a[i]=='y'&&a[i+1]=='o'&&a[i+2]=='u')
            {
                cout<<"we";
                i+=2;
            }
            else cout<<a[i];
        }
        cout<<endl;
    }
    return 0;
}
#include<algorithm>//the best codes
#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s, s1, s2;
    while(getline(cin,s))
    {
        int flag;
        s1 = "you";
        s2 = "we";
        flag = s.find(s1,0);
        while(flag != string::npos)
        {
            s.replace(flag, 3, s2);
            flag = s.find(s1, flag + 1);
        }
        cout << s << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值