题目:
Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.
Sample Input:
10 5 ZOE1 2 4 5 ANN0 3 5 2 1 BOB5 5 3 4 2 1 5 JOE4 1 2 JAY9 4 1 2 5 4 FRA8 3 4 2 5 DON2 2 4 5 AMY7 1 5 KAT3 3 5 4 2 LOR6 4 2 4 1 5
Sample Output:
1 4 ANN0 BOB5 JAY9 LOR6 2 7 ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6 3 1 BOB5 4 7 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 5 9 AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
题目大意:给出每个人选了哪几门课,生成一个课程列表,显示出每门课(按课程代码升序)有哪几个人选了。
跟刚才那题一样,只是倒过来输出了,可以对比着来看。https://blog.youkuaiyun.com/jifenghk/article/details/105928368
解题思路:依旧是用map存储,只不过这回改为了map<int,<vector>string>;(输出时有一个测试点超时。。应该也是cincout的问题,我懒得改了...以后再改。)
代码:
#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
map<int,vector<string>> ma;
int n,c;//学生人数,课程数
//freopen("input.txt","r",stdin);
cin>>n>>c;
string name;//学生姓名
int size;//每个学生选课门数
int k;
for(int i=0;i<n;i++){
cin>>name>>size;
for(int j=0;j<size;j++){
cin>>k;
ma[k].push_back(name);
}
}
//输出map
for(int i=1;i<=c;i++){
cout<<i<<" "<<ma[i].size()<<endl;
sort(ma[i].begin(),ma[i].end());//字母序输出学生姓名
for(int j=0;j<ma[i].size();j++){
cout<<ma[i][j]<<endl;
}
}
return 0;
}
照例膜一下柳神代码:真是又高效又简洁:
解题思路:建立int的二维数组,course[i][j] = k表示第i号课程上的人的一个列表,k是上这个课的学生的姓名所在的字符数组name[i][j]的i下标~~
注意:strcmp返回的不一定是-1,0,1这几个数字,要返回bool变量还需要在后面添加strcmp是大于0还是小于0
https://www.liuchuo.net/archives/2147
#include <iostream>
#include <vector>
#include <algorithm>
#include <string.h>
using namespace std;
char name[40010][5];
vector<int> course[2510];
bool cmp1(int a, int b) {
return strcmp(name[a], name[b]) < 0;
}
int main() {
int n, k;
scanf("%d %d", &n, &k);
for(int i = 0; i < n; i++) {
int cnt, temp;
scanf("%s %d", name[i], &cnt);
for(int j = 0; j < cnt; j++) {
scanf("%d", &temp);
course[temp].push_back(i);
}
}
for(int i = 1; i <= k; i++) {
printf("%d %d\n", i, course[i].size());
sort(course[i].begin(), course[i].end(), cmp1);
for(int j = 0; j < course[i].size(); j++)
printf("%s\n", name[course[i][j]]);
}
return 0;
}