poj 2421(最小生成树)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15536 Accepted: 6291

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source



题目类型:最小生成树

题目描述:建路使得N个村庄互相连通,要求最小的权值。而且,有一些路已经建好了。

题目分析:路已经建好了,相当于该条边已经被加到了最小生成树中。对应的操作就应该是合并村庄,加上此边的权值。
因为是事先建好的路,所以不用加权值。处理完之后再Kruskal就行了。


代码如下:


#include <iostream>
#include <stdio.h>
#include <algorithm>
#define V 101
#define E V * (V-1) / 2
using namespace std;

struct Edge{
    int u;
    int v;
    int w;
};
Edge edge[E];
int rank[V];
int f[V];
int n;

bool cmp(Edge a,Edge b){
    if( a.w < b.w ){
        return true;
    } else {
        return false;
    }
}

void makeSet(){
    for(int i = 1; i <= n; i++){
        f[i] = i;
        rank[i] = 0;
    }
}
int findRoot(int x){
    if( x == f[x]) {
        return x;
    } else {
        return f[x] = findRoot(f[x]);
    }
}
void merge(int a,int b){
    int ra = findRoot(a);
    int rb = findRoot(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]) {
                rank[ra]++;
            }
        }
    }
}


int main()
{
    while(scanf("%d",&n) != EOF){
        int result = 0;
        int k = -1;
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++) {
                int w;
                scanf("%d",&w);
                if( j > i) {
                    k++;
                    edge[k].u = i;
                    edge[k].v = j;
                    edge[k].w = w;
                }
            }
        }
        makeSet();
        int q,a,b;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d",&a,&b);
            merge(a,b);
        }
        sort(edge,edge+k+1,cmp);
        for(int i = 0; i <= k; i++){
            int ru = findRoot(edge[i].u);
            int rv = findRoot(edge[i].v);
            if(ru != rv) {
                result += edge[i].w;
                merge(edge[i].u,edge[i].v);
            }
        }
        printf("%d\n",result);

    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值