Arrange the Bulls
Time Limit: 4000MS | Memory Limit: 65536K | |
Total Submissions: 3856 | Accepted: 1484 |
Description
Farmer Johnson's Bulls love playing basketball very much. But none of them would like to play basketball with the other bulls because they believe that the others are all very weak. Farmer Johnson has N cows (we number the cows from 1 to N) and M barns (we number the barns from 1 to M), which is his bulls' basketball fields. However, his bulls are all very captious, they only like to play in some specific barns, and don’t want to share a barn with the others.
So it is difficult for Farmer Johnson to arrange his bulls, he wants you to help him. Of course, find one solution is easy, but your task is to find how many solutions there are.
You should know that a solution is a situation that every bull can play basketball in a barn he likes and no two bulls share a barn.
To make the problem a little easy, it is assumed that the number of solutions will not exceed 10000000.
So it is difficult for Farmer Johnson to arrange his bulls, he wants you to help him. Of course, find one solution is easy, but your task is to find how many solutions there are.
You should know that a solution is a situation that every bull can play basketball in a barn he likes and no two bulls share a barn.
To make the problem a little easy, it is assumed that the number of solutions will not exceed 10000000.
Input
In the first line of input contains two integers N and M (1 <= N <= 20, 1 <= M <= 20). Then come N lines. The i-th line first contains an integer P (1 <= P <= M) referring to the number of barns cow i likes to play in. Then follow P integers, which give the number of there P barns.
Output
Print a single integer in a line, which is the number of solutions.
Sample Input
3 4 2 1 4 2 1 3 2 2 4
Sample Output
4
我对压缩DP掌握的不是太好,但是这道题的状态转移还是比较好分析。首先要用数组保存牛喜欢的仓库,接下来就是用二进制存储当前的牛入仓库的状态,后一状态从前一状态产生,同时为了保证不会重复转移,在后一状态全部结束时吧前一状态置0。这里用二进制来判断和改变状态确实很好用,另外要注意状态的数组大小,最好是开成最大位数加一位再减去一。
#include<iostream>
#include<cstdio>
#include<memory.h>
using namespace std;
int N,M;
int A[25][25];
int a[(1<<20)+10];
int main()
{
while(scanf("%d%d",&N,&M)!=EOF){
if(N>M) {printf("0\n");continue;}
memset(A,0,sizeof(A));
memset(a,0,sizeof(a));
for(int i=0;i<N;i++){
int n,m;
scanf("%d",&n);
for(int j=0;j<n;j++)
{
scanf("%d",&m);
A[i+1][m-1]=1;
}
}
a[0]=1;
for(int i=0;i<N;i++){
for(int j=(1<<M)-1;j>=0;j--){
if(a[j]==0) continue;//防止状态重复访问
for(int k=0;k<M;k++){
int L;
if((j&(1<<k))!=0) continue;//判断k位置的仓库是否被占
if(A[i+1][k]==0) continue;
L=(j|(1<<k));//刷新状态
a[L]+=a[j];
}
a[j]=0;//将用过的状态删除
}
}
int S=0;
for(int i=0;i<(1<<M);i++){
S+=a[i];
}
printf("%d\n",S);
}
return 0;
}