Climbing Worm

ClimbingWorm

Time Limit : 2000/1000ms (Java/Other)   MemoryLimit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) :1
Font:Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

An inch worm is at the bottom ofa well n inches deep. It has enough energy toclimb u inches every minute, but then has to rest a minute before climbingagain. During the rest, it slips down d inches. The process of climbingand resting then repeats. How long before the worm climbs out of the well?We'll always count a portion of a minute as a whole minute and if the worm justreaches the top of the well at the end of its climbing, we'll assume the wormmakes it out.

Input

There will be multiple problem instances. Each line willcontain 3 positive integers n, u and d. These give the values mentioned in theparagraph above. Furthermore, you may assume d < u and n < 100. A valueof n = 0 indicates end of output.

Output

Each input instance should generate a single integer on aline, indicating the number of minutes it takes for the worm to climb out ofthe well.

Sample Input

10 2 1
20 3 1
0 0 0

Sample Output

17
19

Source

East Central North America 2002

 

 参考代码:

#include <stdio.h>

int main()
{
	int n,u,d;
	int count, sum;
	scanf("%d%d%d",&n,&u,&d);
	while(n)
	{
		sum=count=0;
		while(sum<n)
		{
			sum=sum+u;
			count++;
			if(sum<n)
			{
				sum=sum-d;
				count++;
			}
		}
		printf("%d\n",count);
		scanf("%d%d%d",&n,&u,&d);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值