Coin Game
Time Limit:
1000
MS
Memory Limit:
32768
KB
64bit IO Format:
%I64d & %I64u
Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.
The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.

The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.
Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
Sample Input
2 3 1 3 2
Sample Output
Case 1: first Case 2: second
属于环形博弈,我觉得用一句古语来描述很恰当,叫做
分而治之 。
思想就是将剩余的硬币环一分为二,总是不让你一次取完,你只能二取一,最后的硬币由我来取,从而我获胜。
AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
int t,i,p,j;
long long int n,k;
scanf("%d",&t);
for(i=1;i<=t;i++)
{
scanf("%lld %lld",&n,&k);
printf("Case %d: ",i);
if(k==1)
{
if(n%2==0)
printf("second\n"); //当只能拿一个硬币时,不能做到分而治之,需要特判一下。
else
printf("first\n");
}
else
{
if(n<=k)
printf("first\n");
else
printf("second\n");
}
}
return 0;
}