UVa307Sticks

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input file contains blocks of 2 lines. The first line contains the number of sticks parts after cutting. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output file contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output

6
5

我有话说:
备战NOIPing。
这道题是一道搜索练习题。最重要的是剪枝。
下面再代码中注释剪枝策略。

#include<iostream>
#include<string>
#include<cstring>
#include<sstream>
#include<vector>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
const int maxn=100+10;
const int maxv=50000+10;
const int INF=100000000;
int sum,N,n,L,a[maxn],vis[maxn];
int cmp(int a,int b)
{
    return a>b;
}
int dfs(int cur,int complete,int len)
{
    if(len==L){
        if(++complete==N)return 1;
        else {
            for(cur=0;vis[cur];cur++);
            vis[cur]=1;
            if(dfs(cur+1,complete,a[cur]))return 1;
            vis[cur]=0;
        }
    }else{
        for(int i=cur;i<n;i++){
            if(!vis[i]&&a[i]<=L-len){
                if(i!=0&&a[i]==a[i-1]&&!vis[i-1])continue;//如果该木棒和前一个长度相同但是前一个木棒没有被选上那么这个木棒也不会被选上。
                vis[i]=1;
                if(dfs(i+1,complete,len+a[i]))return 1;
                vis[i]=0;
                if(a[i]==L-len)return 0;//如果这个木棒刚好可以补上得到一根完整L长的木棒,但是选上这根木棒后,后面没办法补成完整的木棒,那么一定是前面有问题,直接剪枝
            }
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)==1&&n){
        int maxa=0;
        sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            maxa=max(maxa,a[i]);
            sum+=a[i];
        }
        sort(a,a+n,cmp);//排序
        //for(int i=0;i<n;i++)printf("%d ",a[i]);
        memset(vis,0,sizeof(vis));
        for(L=maxa;L<=sum/2;L++){//最大到sum/2
            if(sum%L)continue;//原来的木棒长度一定是sum的约数。
            N=sum/L;
            if(dfs(0,0,0))break;
        }
        if(L>sum/2)printf("%d\n",sum);
        else printf("%d\n",L);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值