翻译布尔表达式
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。
Input
多组输入,首先输入一个整数T,代表数据组数。
接下来每组输入为一行字符串,例如: a < b or c < d and e < f
每个符号都用空格间隔。
Output
假链跳到0,真链跳到1,表达式序号从100开始排。
Sample Input
1 a < b or c < d and e < f
Sample Output
100(j<,a,b,1) 101(j,_,_,102) 102(j<,c,d,104) 103(j,_,_,0) 104(j<,e,f,100) 105(j,_,_,103)
Hint
Source
#include<bits/stdc++.h>
using namespace std;
string str;
int jump,tmp;
vector<string>tt;
int main()
{
int n;
scanf("%d\n",&n);
while(n--)
{
getline(cin,str);
str += " end";
jump = 1;tmp = 0;
string s;
stringstream ss(str);
int id = 100;
while(ss >> s)
{
if(s == "or")
{
printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),jump);
jump = id++;
printf("%d(j,_,_,%d)\n",id,id+1);
id ++;
tt.clear();
}
else if(s == "and")
{
printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),id+2);
id ++;
printf("%d(j,_,_,%d)\n",id,tmp);
tmp = id++;
tt.clear();
}
else if(s == "end")
{
printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),jump);
id ++;
printf("%d(j,_,_,%d)\n",id,tmp);
tt.clear();
}
else
tt.push_back(s);
}
}
return 0;
}