LCS 1829: Candies

 


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s8192K373113Standard

All children like candies. One day a group of children are dividing M candies by the following rules.

1. The candies are numbered with 1,2,3…M.

2. One children can select a series of candies from small number to high number.

3. The candy chosen for the first time can be taken away.

4. From the second candy, it can be taken away iff its value is not more than the value of previous one.

Everyone wants to get candies as many as possible. Now assume you are the first child to choose candies, you are to write a program to calculate the largest number of candies you can take.

Input

There may be more than one test case in the input.

The first line of each case is an integer M(M<=1000), number of candies to be divided, followed by M lines indicating values of every candies. They are sorted by their numbers from 1 to M.

Output

For each case, print the answer.

Sample Input

5
5
2
4
1
3

Sample Output

3

#include<iostream>
int main()

 freopen("in.txt","r",stdin);
 freopen("out.txt","w",stdout);
 int n;
 int a[1001],f[1001];
 while(scanf("%d",&n)!=EOF)
 {
  for(int i=1;i<=n;i++)
      {
    scanf("%d",&a[i]);
    f[i]=1;
   }
  for(int i=n;i>=1;i--)
    for(int j=i+1;j<=n;j++)
       if(a[j]<=a[i] && f[i]<f[j]+1)  f[i]=f[j]+1;
  int max=0;
  for(int i=1;i<=n;i++)
    if(f[i]>max) max=f[i];
  printf("%d/n",max);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值